Selasa, 23 Juni 2009

RoboMind, Game untuk programmer pemula

Bagi Anda seorang programmer pemula, ada sebuah game yang menarik buat Anda. Game yang menggabungkan konsep pemrograman dengan Robot. Mungkin game ini cocok pula bagi para programmer yang dulunya bercita-cita ingin membuat robot, namun tidak kesampaian :-) . Game ini bernama RoboMind.


Robomind adalah sebuah game opensource tentang bagaimana mengendalikan pergerakan sebuah robot melalui perintah-perintah menggunakan bahasa pemrograman. Game yang dibuat oleh Arvid Halma dari Universitas Amsterdam ini dapat didownload di URL http://www.robomind.net

Mengapa game ini cocok bagi mereka yang baru belajar pemrograman? Ya… di dalam game ini, kita bisa mengatur sendiri langkah-per langkah kita untuk mengatur gerakan robot, dalam hal ini melatih kemampuan kita dalam penguasaan algoritma dan logika. Selain itu dalam RoboMind ini terdapat pula beberapa struktur pemrograman seperti halnya bahasa pemrograman pada umumnya, seperti bentuk IF, LOOPING, dan PROCEDURE.

Di dalam RoboMind, kita bisa menggerakkan robot untuk bergerak maju, mundur, belok kanan, kiri, mewarnai jalan yang dilalui, mencari sebuah obyek, mengambil sebuah obyek, dan meletakkan obyek melalui perintah-perintah berbentuk function.

Berikut ini beberapa perintah dasar untuk mengatur gerakan si robot.

* forward(n), digunakan untuk menggerakan maju si robot n langkah
* backward(n), digunakan untuk menggerakan ke belakang si robot n langkah
* left(), digunakan untuk membelokkan si robot ke kiri 90 derajad
* right(), digunakan untuk membelokkan si robot ke kanan 90 derajad
* north(n), digunakan untuk mengarahkan robot ke utara, lalu bergerak maju n langkah
* south(n), digunakan untuk mengarahkan robot ke selatan, lalu bergerak maju n langkah
* west(n), digunakan untuk mengarahkan robot ke barat, lalu bergerak maju n langkah
* east(n), digunakan untuk mengarahkan robot ke timur, lalu bergerak maju n langkah

Robot juga bisa disuruh mewarnai path yang dilalui, dengan perintah berikut ini

* paintWhite(), menyuruh robot mewarnai dengan warna putih pada path
* paintBlack(), menyuruh robot mewarnai dengan warna hitam pada path
* stopPainting(), menyuruh robot berhenti mewarnai

Selain mewarnai path yang dilalui, si robot juga bisa disuruh mengambil obyek dan meletakkannya kembali. Berikut ini beberapa perintah untuk melakukan hal tersebut:

* pickUp(), mengambil obyek yang ada di depannya
* putDown(), meletakkan obyek di depannya

Read More »

Sabtu, 20 Juni 2009

Contoh Konfigurasi VLAN menggunakan Catalyst switch




Langkah-langkah di Catalyst Switch 1924:
Switch#config t
Switch(config)#vlan 10
Switch(config)#vlan 20
Switch(config)#interface e0/1
Switch(config-fi)#vlan-membership static 10
Switch(config-if)#interface e0/2
Switch(config-if)#vlan-membership static 10
Switch(config-if)#interface e0/4
Switch(config-if)#vlan-membership static 20
Switch(config-if)#interface e0/5
Switch(config-if)#vlan-membership static 20
Switch(config-if)#interface fastethernet0/26
Switch(config-if)#Trunk On
Switch(config-if)#exit
Switch(config)#ip default gateway 10.1.1.1
Switch(config)# ip add 10.1.1.2 255.255.255.0


Langkah-langkah di Router ICT:
Router-ICT(config)#interface f0/0
Router-ICT(config-if)#description Terhubung ke Switch
Router-ICT(config-if)#exit
Router-ICT(config)#interface f0/0.1
Router-ICT(config-subif)#ip address 10.1.1.1 255.255.255.0
Router-ICT(config-subif)#encapsulation ISL 1
Router-ICT(config-subif)#exit
Router-ICT(config)#interface fastethernet0/0.10
Router-ICT(config-subif)#encapsulation ISL 10
Router-ICT(config-subif)#ip address 10.22.77.130 255.255.255.0
Router-ICT(config-subif)#exit
Router-ICT(config)#interface fastethernet0/0.20
Router-ICT(config-subif)#encapsulation ISL 20
Router-ICT(config-subif)#ip address 192.168.0.1 255.255.255.0



Read More »

GNS3 Simulator Overview

What is GNS3 ?

GNS3 is a graphical network simulator that allows simulation of complex networks.

To allow complete simulations, GNS3 is strongly linked with :

* Dynamips, the core program that allows Cisco IOS emulation.
* Dynagen, a text-based front-end for Dynamips.
* Pemu, a Cisco PIX firewall emulator based on Qemu.


GNS3 is an excellent complementary tool to real labs for Cisco network engineers, administrators and people wanting to pass certifications such as CCNA, CCNP, CCIP or CCIE.

It can also be used to experiment features of Cisco IOS or to check configurations that need to be deployed later on real routers.

This project is an open source, free program that may be used on multiple operating systems, including Windows, Linux, and MacOS X.
Features overview

* Design of high quality and complex network topologies.
* Emulation of many Cisco router platforms and PIX firewalls.
* Simulation of simple Ethernet, ATM and Frame Relay switches.
* Connection of the simulated network to the real world!
* Packet capture using Wireshark.

Important notice: users have to provide their own Cisco IOS to use with GNS3.

Download here
Read More »

Rabu, 17 Juni 2009

Understanding and Implementing Quality of Service in Cisco Multilayer Switched Networks

Configuration Exercise: Configuring QoS on Cisco IOSBased Catalyst Switches
Complete this configuration exercise to familiarize yourself with basic QoS configuration on Cisco IOSbased Catalyst switches as discussed in this chapter.
Required Resources


The resources and equipment required to complete this exercise are as follows (the last two items are optional):

*
Catalyst 3550
*
Terminal server or workstation connected directly to the console port of the Catalyst 3550 or out-of-band access to the Catalyst 3550
*
Cisco IP Phones infrastructure supporting voice calls (this resource verifies the configuration and is not mandatory)
*
Traffic generator (this resource verifies the configuration and is not mandatory)

Exercise Objective
The purpose of this exercise is to configure a Cisco IOSbased Catalyst switch for the following QoS features:

*
Classification
*
Marking
*
Policing
*
Congestion management
*
Congestion avoidance

The exercise exposes topics such as VLANs and spanning tree found in others chapters of this book. Nevertheless, the main purpose of this exercise is to demonstrate a QoS configuration. In this configuration exercise, your goal is to configure a Catalyst 3550 for the following QoS features:

*
Trust ingress DSCP values for interfaces FastEthernet0/1 through 0/10 when a Cisco IP Phone is attached
*
Reclassify frames on interface FastEthernet0/11 for a CoS value of 4
*
Mark ingress TCP Port 30000 frames on interface FastEthernet0/12 with a DSCP value of16
*
Apply strict-priority queuing for VoIP traffic
*
Configure high-priority queues to have a 2-to-1 (2:1) priority over low-priority queues

Network Diagram
Figure 10-18 shows the network layout for this configuration exercise
Command List

In this configuration exercise, you will use the commands listed in Table 10-7, which are in alphabetical order so that you can easily locate the information you need. Refer to this list if you need configuration command assistance during the configuration exercise. The table includes only the specific parameters used in the example and not all the available options for the command

mls qos


Globally enables QoS

mls qos trust device cisco-phone


Interface configuration command for trusting when a Cisco Phone is learned via CDP on the respective interface; works in conjunction with the mls qos trust dscp and mls qos trust cos commands

mls qos trust dscp


Interface configuration command for trusting DSCP values for ingress frames

no shutdown


Configures an interface in the Administrative UP state

policy-map policy_map_name


Enters the policy-map configuration submode

priority-queue out


Configures queue 4 on the Catalyst 3550 family of switches as a priority queue

service-policy input | output policy-map-name


Maps a policy map to an interface for ingress or egress traffic

set ip dscp dscp_value


Policy-map class action for marking DSCP

show mls qos interface FastEthernet | GigabitEthernet interface


Displays the trusting configuration of an interface

spanning-tree portfast


Configures an interface for the spanning-tree PortFast feature

Switchport


Configures an interface for Layer 2 operation

switchport access vlan vlan-id


Configures an interface for a specific VLAN-ID

vlan vlan-id


Adds or removes a VLAN-ID in the VLAN database

wrr-queue bandwidth weight1 weight2 weight3 weight4


For weight1 weight2 weight3 weight4, enter the ratio that determines the frequency in which the WRR scheduler dequeues packets; separate each value with a space (the range is 1 to 65536)

wrr-queue cos-map queue-id cos1 ... cos8


Configures CoS value to egress queue mapping
Task 1: Globally Enable QoS

Step1 Connect the Catalyst switch to a terminal server or directly to the workstation's serial port for in-band connectivity.

Step2 Globally enable QoS features on the switch.

Switch#configure terminal
Switch(config)#mls qos

Step3 Verify that QoS is globally enabled.

Switch(config)#do show mls qos
QoS is enabled

NOTE

The Cisco IOS do command is a recent addition to Cisco IOS to allow execution of privileged mode commands within configuration mode. This command saves the time and annoyance of exiting out and re-entering configuration mode. do is only found in the most recent Cisco IOS version, so it may not be supported in your version. If not, exit configuration mode and type the command (minus the keyword do) in privileged mode.

Recall that for the Catalyst 4000 and 4500 families of switches running Cisco IOS, qos commands are not prefixed with the keyword mls.
Task 2: Configure the Switch to Trust DSCP on Interfaces FastEthernet0/1 Through 0/10 If a Cisco IP Phone Is Attached

Step1 Enter the range command to configure multiple interfaces simultaneously.

Switch(config)#interface range FastEthernet 0/1 -10

Step2 Specify an access VLAN for IP Phones (voice VLANs are not used in this exercise).

Switch(config-if-range)#switchport access vlan 500

Step3 Configure the switch to trust DSCP for incoming frames only if Cisco IP Phones are attached to the interface.

Switch(config-if-range)#mls qos trust dscp
Switch(config-if-range)#mls qos trust device cisco-phone

Step4 Configure the interfaces for spanning-tree PortFast.

Switch(config-if-range)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
%Portfast will be configured in 10 interfaces due to the range command
but will only have effect when the interfaces are in a non-trunking mode.

Step5 Enable the interfaces.

Switch(config-if-range)#no shutdown

Step6 Verify the QoS configuration.

Switch#show mls qos interface FastEthernet 0/1
FastEthernet0/1
trust state: not trusted
trust mode: trust dscp
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
trust device: cisco-phone

Task 3: Configure the Switch to Classify All Incoming Frames on Interface FastEthernet 0/11 with a CoS Value of 4 for Untagged Frames

Step1 Enter the interface configuration mode for FastEthernet0/11.

Switch(config)#interface FastEthernet 0/11

Step2 Configure the interface to classify all ingress frames with a CoS value of 4.

Switch(config-if)#mls qos cos 4

Step3 Verify the QoS configuration.

Switch#(config-if)#do show mls qos interface FastEthernet 0/11
FastEthernet0/11
trust state: not trusted
trust mode: not trusted
COS override: dis
default COS: 4
DSCP Mutation Map: Default DSCP Mutation Map
trust device: none

Task 4: Configure a Policy Map, Class Map, and the Interface Such That All Ingress TCP Port 30000 Packets on FastEthernet0/11 Have Their DSCP Set to 16

Step1 Configure an access list to match packets on TCP port 30000.

Switch(config)#access-list 100 permit tcp any any eq 30000

Step2 Configure a traffic profile using a class map.

Switch(config)#class-map TCP-PORT-30k
Switch(config-cmap)#match access-group 100
Switch(config-cmap)#exit

Step3 Configure a policy map to apply the class map in Step 2 to the class action of setting the DSCP to 16.

Switch(config)#policy-map BCMSN
Switch(config-pmap)#class TCP-PORT-30k
Switch(config-pmap-c)#set ip dscp 16
Switch(config-pmap-c)#exit
Switch(config-pmap)#exit

Step4 Apply the policy-map ingress on interface FastEthernet0/11.

Switch(config)#interface FastEthernet 0/11
Switch(config-if)#service-policy input BCMSN
Switch(config-if)#exit

Step5 Verify the policy-map configuration.

Switch#show policy-map interface FastEthernet 0/11

FastEthernet0/11

service-policy input: BCMSN

class-map: TCP-PORT-30k (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
match: access-group 100

class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
match: any
0 packets, 0 bytes
5 minute rate 0 bps

Task 5: Configure All Egress Queues Such That CoS Values 4, 6, and 7 Use Queue 3 and a CoS Value of 5 Uses Queue 4

Step1 Enter the range command to configure multiple interfaces simultaneously.

Switch(config)#interface range FastEthernet 0/1 -24

Step2 Configure interfaces for appropriate CoS mapping.

Switch(config-if)#wrr-queue cos-map 4 5
Switch(config-if)#wrr-queue cos-map 3 4 6 7
Switch(config-if)#exit

Task 6: Configure Queue 4 as a Strict-Priority Queue

Step1 Enter the range command to configure multiple interfaces simultaneously.

Switch(config)#interface range FastEthernet 0/1 -24

Step2 Configure queue 4 as a strict-priority queue.

Switch(config-if)#priority-queue out

Task 7: Configure WRR Weights Such That Queue 3 Receives Twice as Much Service as Any Other Single Queue

Step1 Enter the range command to configure multiple interfaces simultaneously.

Switch(config)#interface range FastEthernet 0/1 -24

Step2 Configure queue 3 with twice the service level as that of any other queue.

Switch(config-if)#wrr-queue bandwidth 20 20 40 20

Step3 Verify the WRR configuration.

Switch#show mls qos interface FastEthernet 0/1 queueing
FastEthernet0/1
Egress expedite queue: ena
wrr bandwidth weights:
qid-weights
1 - 20
2 - 20
3 - 40
4 - 20 when expedite queue is disabled
Cos-queue map:
cos-qid
0 - 1
1 - 1
2 - 2
3 - 2
4 - 3
5 - 4
6 - 3
7 - 3

Task 8: Verify All Configurations by Viewing Interface Statistics

Switch#show mls qos interface FastEthernet 0/1 statistics
FastEthernet0/1
Ingress
dscp: incoming no_change classified policed dropped (in bytes)
Others: 97663325 87828650 9834675 0 0
Egress
dscp: incoming no_change classified policed dropped (in bytes)
Others: 30540345 n/a n/a 0 0



Read More »

Monitor dan Memblok Trafik Virus Pada Cisco Router

Router merupakan sebuah device yang berfungsi untuk meneruskan paket-paket dari sebuah network ke network yang lainnya (baik LAN ke LAN atau LAN ke WAN) sehingga host-host yang ada pada sebuah network bisa berkomunikasi dengan host-host yang ada pada network yang lain. Router menghubungkan network-network tersebut pada network layer dari model OSI, sehingga secara teknis Router adalah Layer 3 Gateway.



Selain itu juga router dapat menangkap dan melihat aktivitas trafik dalam jaringan, sehingga memudahkan kita untuk mengklasifikasikan trafik dan membuang paket-paket yang tidak diperlukan.

Berkembangnya virus-virus komputer yang sangat cepat, cukup merugikan para penyedia jaringan dan pengguna komputer. Serangan virus ini telah banyak mengkonsumsi bandwidth sehingga trafik aplikasi yang sebenarnya tidak bisa dilewatkan melalui jaringan karena jaringan telah dipenuhi oleh paket-paket virus.

Berikut ini tulisan yang menyajikan cara memonitor trafik dan memblok paket virus dengan menggunakan router Cisco.

Untuk menampung semua trafik yang keluar masuk, harus dibuatkan tempat yang biasanya disebut log.

Pada router cisco, buffer log tidak aktfi secara default. Oleh karena itu kita harus mengaktifkannya sebelum menampung trafik yang akan kita lihat.

Cara mengaktifkan log buffer pada Router Cisco:

Router(config)# logging buffered 4096
Router(config)# exit

Angka 4096 mempunyai satuan bytes, jadi tempat/memori yang disediakan untuk menangkat trafik sebesar 4096 Bytes.

Setelah itu, kita membuat profile untuk menangkap trafik dengan menggunakan Access Control List (ACL) extended.

Contoh :

Konfigurasi access-list 101

Router# config t
Router(config)# access-list 101 permit icmp any any log
Router(config)# access-list 101 permit tcp any any gt 0 log
Router(config)# access-list 101 permit udp any any gt 0 log
Router(config)# access-list 101 permit ip any any log

Pengertian permit berarti semua paket (icmp, tcp, udp, ip) diijinkan lewat

Selanjutnya terapkan Access-List yang sudah dibuat pada interface yang akan kita tangkap trafiknya.

Misal kita ingin menangkap trafik yang masuk ke port Fast Ethernet 0 : (dapat diterapkan di semua interface, seperti : E0, S0, S1.1, S2/0.1, ATM0/0.1, dll)

Router(config)# int fa0
Router(config-if)# ip access-group 101 in
Router(config-if)# exit

Agar hasil log dapat terlihat Tanggal dan Jam-nya, maka harus dikonfigurasi sebagai berikut:

Router(config)# service timestamps log datetime localtime
Router(config)# exit
Router#clock set 14:00:00 17 May 2004

Setelah selesai, kita dapat melihat semua trafik yang masuk ke Fast Ethernet 0:

Perintah yang digunakan adalah : show log

Router# show log

May 17 14:02:38: %SEC-6-IPACCESSLOGP: list 101 permitted tcp 172.21.0.182(1019) -> 192.168.134.82(515), 2 packets

May 17 14:02:44: %SEC-6-IPACCESSLOGDP: list 101 permitted icmp 192.168.134.2 -> 192.168.134.42 (3/13), 6 packets

May 17 14:02:44: %SEC-6-IPACCESSLOGP: list 101 permitted tcp 172.21.0.182(1019) -> 192.168.134.43(515), 1 packet

May 17 14:03:03: %SEC-6-IPACCESSLOGP: list 101 permitted tcp 172.21.0.155(1014) -> 192.168.134.67(515), 2 packets

May 17 14:03:05: %SEC-6-IPACCESSLOGP: list 101 permitted tcp 172.21.0.182(1005) -> 192.168.134.67(515), 2 packets

Dari data trafik baris pertama di atas, paket tcp port 1019 dengan IP 172.21.0.182 masuk ke port Fast Ethernet 0 dengan tujuan IP 192.168.134.82 menggunakan port 515 sebanyak 2 paket, terjadi pada tanggal 17 May 2004 jam 14:02:38.

Dari data trafik baris pertama di atas, paket tcp port 1019 dengan IP 172.21.0.182 masuk ke port Fast Ethernet 0 dengan tujuan IP 192.168.134.82 menggunakan port 515 sebanyak 2 paket, terjadi pada tanggal 17 May 2004 jam 14:02:38.Dari data trafik baris pertama di atas, paket tcp port 1019 dengan IP 172.21.0.182 masuk ke port Fast Ethernet 0 dengan tujuan IP 192.168.134.82 menggunakan port 515 sebanyak 2 paket, terjadi pada tanggal 17 May 2004 jam 14:02:38.Untuk melihat throughput atau utilisasi pada interface Fast Ethernet 0, dapat menggunakan perintah:

Router# sho int fa0

….
5 minute input rate 11264000 bits/sec, 2378 packets/sec
5 minute output rate 5203000 bits/sec, 3060 packets/sec
……

Virus Jaringan

PC yang terkena virus akan selalu mengirimkan paket-paket ke jaringan dalam jumlah besar dalam waktu singkat.

Jika pada saat kita menangkap trafik pada suatu interface, terdapat pola paket yang sangat banyak dan menggunakan port TCP, UDP atau ICMP yang sama, kemungkinan jaringan ini terkena virus.

Berikut contoh-contoh paket virus dalam jaringan :

Salah satu jenis Virus Blaster menggunakan TCP port 135, virus ini dapat memenuhi jaringan dan menyebabkan aplikasi di jaringan menjadi lambat atau bahkan hang. Paket ini akan terus memenuhi jaringan walaupun kondisi komputer sedang tidak melakukan aktivitas.

May 19 14:25:48: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.69(2865) -> 129.74.248.15(135), 1 packet

May 19 14:25:49: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.66(4283) -> 10.239.97.117(135), 1 packet

May 19 14:25:50: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.69(2897) -> 129.74.248.47(135), 1 packet

May 19 14:25:51: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.70(3832) -> 166.58.195.45(135), 1 packet

May 19 14:25:52: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.68(2189) -> 68.44.91.87(135), 1 packet

May 19 14:25:53: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.70(3864) -> 166.58.195.77(135), 1 packet

May 19 14:25:54: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.66(4335) -> 10.239.97.167(135), 1 packet

May 19 14:25:55: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.69(2947) -> 129.74.248.97(135), 1 packet

May 19 14:25:56: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.66(4369) -> 10.239.97.199(135), 1 packet

May 19 14:25:57: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.68(2239) -> 68.44.91.137(135), 1 packet

May 19 14:25:58: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.70(3914) -> 166.58.195.127(135), 1 packet

Jenis Virus Blaster yang lain menggunakan TCP port 445, 139 dan UDP port 137 (ada juga yang menggunakan port 138, tetapi tidak ditampilkan di sini)

May 25 15:46:46: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2774) -> 64.120.84.40(445), 1 packet

May 25 15:46:47: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2776) -> 64.120.84.41(445), 1 packet

May 25 15:46:48: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2778) -> 64.120.84.42(445), 1 packet

May 25 15:46:49: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2780) -> 64.120.84.43(445), 1 packet

May 25 15:46:50: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2782) -> 64.120.84.44(445), 1 packet

May 25 15:46:51: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2784) -> 64.120.84.45(445), 1 packet

May 25 15:46:52: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2787) -> 64.120.84.46(139), 1 packet

May 25 15:46:53: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2789) -> 64.120.84.47(139), 1 packet

May 25 15:46:54: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2790) -> 64.120.84.48(445), 1 packet

May 25 15:46:55: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2792) -> 64.120.84.49(445), 1 packet

May 25 15:46:56: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2794) -> 64.120.84.50(445), 1 packet

May 25 15:48:06: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2922) -> 64.120.84.111(139), 1 packet

May 25 15:48:07: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2924) -> 64.120.84.112(139), 1 packet

May 25 15:48:08: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2940) -> 64.120.84.119(139), 1 packet

May 25 15:48:10: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2944) -> 64.120.84.121(139), 1 packet

May 25 15:48:11: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2952) -> 64.120.84.125(445), 1 packet

May 25 15:48:12: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2955) -> 64.120.84.126(139), 1 packet

May 25 15:48:13: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2956) -> 64.120.84.127(445), 1 packet

May 25 15:48:14: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2959) -> 64.120.84.128(139), 1 packet

May 25 15:48:15: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2962) -> 64.120.84.129(139), 1 packet

May 25 15:48:16: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2964) -> 64.120.84.130(139), 1 packet

May 25 15:48:17: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2966) -> 64.120.84.131(139), 1 packet

May 25 15:48:18: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2968) -> 64.120.84.132(139), 1 packet

May 25 15:48:19: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2970) -> 64.120.84.133(139), 1 packet

May 25 15:48:21: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2974) -> 64.120.84.135(139), 1 packet

May 25 15:48:22: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2976) -> 64.120.84.136(139), 1 packet

May 25 15:48:23: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2978) -> 64.120.84.137(139), 1 packet

May 25 15:48:24: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2981) -> 64.120.84.138(139), 1 packet

May 25 15:48:25: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2984) -> 64.120.84.139(139), 1 packet

May 25 15:48:26: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2985) -> 64.120.84.140(445), 1 packet

May 25 15:48:27: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2979) -> 64.120.84.138(445), 1 packet

May 25 15:48:28: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2984) -> 64.120.84.139(139), 1 packet

May 25 15:48:29: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2992) -> 64.120.84.143(139), 1 packet

May 25 15:48:30: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2974) -> 64.120.84.135(139), 1 packet

May 25 15:48:32: %SEC-6-IPACCESSLOGP: list 107 permitted tcp 202.152.18.230(2978) -> 64.120.84.137(139), 1 packet

May 18 16:20:48: %SEC-6-IPACCESSLOGP: list 104 permited udp 10.49.100.230(1028) -> 19.135.133.55(137), 1 packet

May 18 16:20:49: %SEC-6-IPACCESSLOGP: list 104 permited tcp 10.49.12.124(4616) -> 10.14.44.151(445), 1 packet

May 18 16:20:50: %SEC-6-IPACCESSLOGP: list 104 permited tcp 10.49.148.98(2979) -> 10.49.181.197(445), 1 packet

May 18 16:20:51: %SEC-6-IPACCESSLOGP: list 104 permited tcp 10.49.20.116(4176) -> 10.49.239.149(445), 1 packet

May 18 16:20:52: %SEC-6-IPACCESSLOGP: list 104 permited udp 10.49.18.195(1030) -> 139.64.66.76(137), 1 packet

May 18 16:20:53: %SEC-6-IPACCESSLOGP: list 104 permited udp 10.49.12.34(1027) -> 120.134.165.57(137), 1 packet

May 18 16:20:54: %SEC-6-IPACCESSLOGP: list 104 permited udp 10.49.6.35(1031) -> 3.151.81.106(137), 1 packet

May 18 16:20:55: %SEC-6-IPACCESSLOGP: list 104 permited tcp 10.49.20.115(3517) -> 10.49.217.164(445), 1 packet

May 18 16:20:56: %SEC-6-IPACCESSLOGP: list 104 permited tcp 10.49.2.131(1903) -> 10.174.107.77(445), 1 packet

May 18 16:20:57: %SEC-6-IPACCESSLOGP: list 104 permited tcp 10.49.22.68(4704) -> 10.57.51.106(445), 1 packet

May 18 16:20:58: %SEC-6-IPACCESSLOGP: list 104 permited udp 10.49.5.99(1027) -> 132.70.123.242(137), 1 packet

May 19 14:25:48: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.69(2865) -> 129.74.248.15(135), 1 packet

May 19 14:25:49: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.66(4283) -> 10.239.97.117(135), 1 packet

May 19 14:25:50: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.69(2897) -> 129.74.248.47(135), 1 packet

May 19 14:25:51: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.70(3832) -> 166.58.195.45(135), 1 packet

May 19 14:25:52: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.68(2189) -> 68.44.91.87(135), 1 packet

May 19 14:25:53: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.70(3864) -> 166.58.195.77(135), 1 packet

May 19 14:25:54: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.66(4335) -> 10.239.97.167(135), 1 packet

May 19 14:25:55: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.69(2947) -> 129.74.248.97(135), 1 packet

May 19 14:25:56: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.66(4369) -> 10.239.97.199(135), 1 packet

May 19 14:25:57: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.68(2239) -> 68.44.91.137(135), 1 packet

May 19 14:25:58: %SEC-6-IPACCESSLOGP: list 102 permitted tcp 10.236.48.70(3914) -> 166.58.195.127(135), 1 packet

Paket Virus Welchia/Nachi:

Oct 22 10:59:50: %SEC-6-IPACCESSLOGDP: list 101 permitted icmp 202.152.13.98 -> 192.170.211.87 (8/0), 1 packet

Oct 22 10:59:51: %SEC-6-IPACCESSLOGDP: list 101 permitted icmp 202.152.13.98 -> 192.170.211.248 (8/0), 1 packet

Oct 22 10:59:52: %SEC-6-IPACCESSLOGDP: list 101 permitted icmp 202.152.13.98 -> 192.170.212.186 (8/0), 1 packet

Oct 22 10:59:53: %SEC-6-IPACCESSLOGDP: list 101 permitted icmp 202.152.13.98 -> 192.170.213.46 (8/0), 1 packet

Dengan menggunakan Router kita dapat memblok paket-paket tersebut diatas agar tidak menulari jaringan yang lain atau memenuhi jaringan WAN.

Bloking paket virus dilakukan di sisi router pada interface yang paling dekat dengan keberadaan jaringan yang bervirus.

Contoh cara melakukan Bloking Paket pada virus Blaster yang menggunakan TCP port 445 dan UDP port 137 adalah dengan menggunakan Access Control List (ACL) sebagai berikut :

Router# config t
Router(config)# access-list 104 deny tcp any any eq 445 log
Router(config)# access-list 104 deny udp any any eq 137 log
Router(config)# access-list 104 permit ip any any

Catatan : Jangan lupa di akhir command untuk selalu memasang permit ip any any , setelah anda melakukan bloking dengan perintah deny. Jika anda tidak memasang permit ip any any, maka semua paket akan diblok.

Selanjutnya kita pasang access-list 104 di atas, pada interface tempat masuknya virus, misal di interface ethernet0:

Router(config)# int e0
Router(config-if)#ip access-group 104 in
Router(config-if)# exit

Untuk melihat hasilnya adalah sebagai berikut :

Router# sho log

May 18 16:21:08: %SEC-6-IPACCESSLOGP: list 104 denied udp 169.254.166.50(137) -> 169.254.255.255(137), 1 packet

May 18 16:21:09: %SEC-6-IPACCESSLOGP: list 104 denied tcp 10.49.151.68(1339) -> 10.49.35.78(445), 1 packet

May 18 16:21:10: %SEC-6-IPACCESSLOGP: list 104 denied udp 10.49.100.230(1028) -> 4.71.4.82(137), 1 packet

May 18 16:21:11: %SEC-6-IPACCESSLOGP: list 104 denied udp 10.49.19.130(1027) -> 46.33.60.237(137), 1 packet

May 18 16:21:12: %SEC-6-IPACCESSLOGP: list 104 denied udp 10.49.7.194(1028) -> 140.120.202.83(137), 1 packet

May 18 16:21:13: %SEC-6-IPACCESSLOGP: list 104 denied tcp 10.49.15.132(3882) -> 10.74.93.59(445), 1 packet

May 18 16:21:14: %SEC-6-IPACCESSLOGP: list 104 denied tcp 10.49.20.115(3562) -> 185.142.133.192(445), 1 packet

May 18 16:21:15: %SEC-6-IPACCESSLOGP: list 104 denied tcp 10.49.12.124(3058) -> 10.228.79.203(445), 1 packet

May 18 16:21:16: %SEC-6-IPACCESSLOGP: list 104 denied tcp 10.49.12.40(3571) -> 31.7.189.248(445), 1 packet

May 18 16:21:17: %SEC-6-IPACCESSLOGP: list 104 denied udp 10.49.13.130(1026) -> 14.0.106.191(137), 1 packet

May 18 16:21:18: %SEC-6-IPACCESSLOGP: list 104 denied udp 10.49.15.99(1029) -> 62.178.109.147(137), 1 packet

May 18 16:21:19: %SEC-6-IPACCESSLOGP: list 104 denied udp 10.49.8.105(1027) -> 144.203.127.85(137), 1 packet

May 18 16:21:20: %SEC-6-IPACCESSLOGP: list 104 denied udp 10.49.8.6(1027) -> 119.123.155.124(137), 1 packet

May 18 16:21:21: %SEC-6-IPACCESSLOGP: list 104 denied tcp 10.49.20.116(4314) -> 17.101.32.39(445), 1 packetTerlihat bahwa semua paket yang menggunakan TCP port 445 dan UDP port 137 akan di Deny (blok).Terlihat bahwa semua paket yang menggunakan TCP port 445 dan UDP port 137 akan di Deny (blok).Hal ini sangat bermanfaat jika jaringan kita menggunakan WAN.

Terlihat bahwa semua paket yang menggunakan TCP port 445 dan UDP port 137 akan di Deny (blok).Hal ini sangat bermanfaat jika jaringan kita menggunakan WAN.Misal kita menggunakan WAN Frame Relay dengan kecepatan 64 Kbps. Jika suatu LAN 100 Mbps di remote terkena virus seperti diatas, maka semua paket virus ini akan menyebar dan masuk ke WAN yang mempunyai kecepatan hanya 64 Kbps. Dapat dibayangkan pasti jaringan WAN yang 64 kbps ini akan penuh, dan user-user di remote tidak akan bisa melakukan hubungan ke jaringan pusat.

Dengan dilakukan bloking seperti cara di atas, maka jaringan WAN 64 Kbps ini akan bersih dan tetap terjaga pemakaian bandwidthnya.

Selamat mencoba!!!

daftar port : disini

sumber tulisan : disini
Read More »

Senin, 15 Juni 2009

Virus Sandra Dewi semakin menggila

Hati-hati bila anda menemukan file Sandra Dewi Bugil, karena akhir-akhir ini dilaporkan virus sadra dewi bugil sedang mengganas.

Adi Saputera, pakar keamanan dari Vaksincom menjelaskan, Norman Security Suite (NSS) dengan teknologi Sandbox dan DNS Matching tanpa update mendeteksi virus Sandra Dewi sebagai new unkown virus. NSS setelah update mengidentifikasi Sandra Dewi Bugil.exe sebagai W32/Sadra.A

Ciri-ciri dari file virus ini, diantaranya sebagai berikut:
* Memiliki ukuran file sebesar 132 kb.
* Mempunyai type file Application.
* Berextension file .exe.
* Memiliki icon gambar (JPEG image).

Dilanjutkan Adi, virus Sandra Dewi dibuat dengan menggunakan bahasa pemrograman visual basic. Jika virus berhasil menginfeksi, maka ia akan membuat beberapa file virus diantaranya :
* C:\Sandra Dewi Bugil.exe (pada semua root drive)
* C:\Documents and Settings\%user%\Start Menu\Programs\Startup\Sandra Dewi Bugil.exe
* C:\WINDOWS\Sandra Dewi Bugil.exe
* C:\WINDOWS\system32\ Sandra Dewi Bugil.exe
* Membuat duplikat file virus pada setiap folder yang ada pada removable drive/usb.

"Masih ingat dengan virus Blue Fantasy, virus yang menampilkan pesan sebelum login, dan kini virus Sandra Dewi juga menampilkan sebuah pesan," ujarnya seperti yang dikutip dari detikinet..com, Jumat (12/6/2009).

Sebagai bentuk pertahanan, masih kata Adi, virus akan mencoba melakukan usaha blok terhadap beberapa fungsi Windows. Beberapa fungsi Windows yang diblok diantaranya sebagai berikut :
* Folder Options (dilakukan untuk mencegah akses terhadap file/folder yang disembunyikan)
* Registry Editor (dilakukan untuk mencegah akses perbaikan registry)
* Search/Find (dilakukan untuk mencegah dari pembersihan virus)
* Command Prompt (dilakukan untuk mencegah dari proses kill virus)
* Task Manager (dilakukan untuk mencegah proses monitoring virus)
* Control Panel (dilakukan untuk mencegah akses kontrol dari OS komputer)
* MsConfig/System Configuration Utility (dilakukan untuk mencegah akses pada startup)

Selain itu, virus juga mencoba melakukan usaha blok terhadap beberapa fungsi Windows yang lain seperti diantaranya :
* Disable klik kanan pada desktop.
* Disable 'All Programs' pada Start Menu.
* Disable menu Log Off/Turn Off pada Start Menu.

Dengan usaha ini, virus mencoba agar pengguna komputer kesulitan dalam menjalankan program tertentu, dan bahkan kesulitan untuk me-restart, log-off maupun shutdown komputer.

Read More »

Newsletter